首页 > K线分析 > K线图

布林宝塔线选股 这份通达信选股公式请收好

在股票市场上,宝塔线是什么意思呢?宝塔线指标,又称为TOWER指标。在中长期技术分析工具中,宝塔线与K线及点状图相类似并注重股价分析的工具。那么,在通信达软件中,布林宝塔线选股方式是什么呢?一起来看看。

布林宝塔线选股
布林宝塔线选股

宝塔线指标TOWER是以不同颜色(或虚实体)的棒线来区分股价涨跌的一种图表型指标。它主要是将股价多空之间的争斗的过程和力量的转变表现在图表中,借以研判未来股价的涨跌趋势及选择适当的买卖时机。

其实,宝塔线的特征与点状图类似,亦即并非记载每天或每周的股价变动过程,而乃系当股价续创新高价(或创新低价),抑或反转上升或下跌时,再予以记录,绘制。

布林宝塔线选股公式

boll:MA(CLOSE,20),COLOR888888;

UPPER:BOLL+2*STD(CLOSE,20),COLOR888888;

LOWER:BOLL-2*STD(CLOSE,20),COLOR888888;

上涨:IF(BOLLREF(BOLL,1),BOLL,DRAWNULL),COLORRED;

VAR1:=CLOSEREF(CLOSE,1) AND CLOSEREF(CLOSE,2);

VAR2:=REF(VAR1,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR3:=REF(VAR2,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR4:=REF(VAR3,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR5:=REF(VAR4,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR6:=REF(VAR5,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR7:=REF(VAR6,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR8:=REF(VAR7,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR9:=REF(VAR8,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VARA:=REF(VAR9,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VARB:=REF(VARA,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VARC:=REF(VARB,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VARD:=CLOSEREF(CLOSE,1) AND CLOSEREF(CLOSE,2);

VARE:=REF(VARD,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VARF:=REF(VARE,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR10:=REF(VARF,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR11:=REF(VAR10,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR12:=REF(VAR11,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR13:=REF(VAR12,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR14:=REF(VAR13,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR15:=REF(VAR14,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR16:=REF(VAR15,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR17:=REF(VAR16,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

VAR18:=REF(VAR17,1) AND CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2);

STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR

VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),1,0),COLORRED;

STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR

VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),1,0),COLORCYAN;

VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR

VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;

STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),1,0),COLORYELLOW;{黄色}

VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR

VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;

STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1,0),COLORCYAN;

STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),1,0),COLORCYAN;{空转多}

STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1,0),COLORRED;{多转空};

版权声明

本文仅代表作者观点,不代表本站立场。
本文系作者授权发表,未经许可,不得转载。
本文地址:www.kxianxueyuan.com/kxianfenxi/3656.html

Copyright©2021 K线学院

渝ICP备17005671号-2

备案 渝公网安备 50011202501214号

Powered By K线学院

扫描二维码关注公众号