首页 > 技术指标 > DMI

dmi指标优化 附上通达信软件中公式

众所周知,在股票市场上,不同的指标,使用的方式和作用都是不一样的,其中,DMI指标作为一种趋势判断的工具,并不可以用来直接指导买卖,下面小编为大家带来通达信软件中dmi指标优化公式。

dmi指标优化
dmi指标优化

DMI指标又叫动向指标或趋向指标,其全称叫“Directional Movement Index,简称DMI”,也是由美国技术分析大师威尔斯·威尔德(Wells Wilder)所创造的,是一种中长期股市技术分析(Technical Analysis)方法。

DMI指标是通过分析股票价格在涨跌过程中买卖双方力量均衡点的变化情况,即多空双方的力量的变化受价格波动的影响而发生由均衡到失衡的循环过程,从而提供对趋势判断依据的一种技术指标

DMI指标共有+DI(即PDI,下同)、-DI(即MDI,下同)、ADX、ADXR四条线,也是它的四个参数值,它分为多空指标(+DI、-DI)和趋向指标(ADX、ADXR)两组指标。

在应用时,DMI指标的研判主要集中在两个方面:一方面是分析上升指标+DI、下降指标-DI和平均动向指标ADX之间的关系;另一方面是对行情的趋势及转势特征的判断,其中,+DI和-DI两条曲线的走势关系是判断能否买卖的信号,ADX则是判断未来行情发展趋势的信号。

通达信优化DMI指标公式

N:=14;

M:=6;

MTR:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);

HD:=HIGH-REF(HIGH,1);

LD:=REF(LOW,1)-LOW;

DMP:=SUM(IF(HD0&&HDLD,HD,0),N);

DMM:=SUM(IF(LD0&&LDHD,LD,0),N);

PDI:=DMP*100/MTR;

MDI:=DMM*100/MTR;

ADX: MA(ABS(MDI-PDI)/(MDI+PDI)*100,M);

ADXR:(ADX+REF(ADX,M))/2;

DRAWBAND(ADX,RGB(255,0,0),ADXR,RGB(56,94,35));

做多:PDI,COLORRED,LINETHICK2;

做空:MDI,COLORCYAN,LINETHICK2;

20,COLORRED,DOTLINE;

50,COLORWHITE,DOTLINE;

DRAWICON(CROSS(PDI,MDI),做多-5,1);

DRAWICON(CROSS(MDI,PDI),做空+5,2);

版权声明

本文仅代表作者观点,不代表本站立场。
本文系作者授权发表,未经许可,不得转载。
本文地址:www.kxianxueyuan.com/jishuzhibiao/4101.html

Copyright©2021 K线学院

渝ICP备17005671号-2

备案 渝公网安备 50011202501214号

Powered By K线学院

扫描二维码关注公众号